Telephone
Incident Report for GleSYS
Resolved
The issue was resolved by the telephone-provider.
Posted Mar 02, 2021 - 16:51 CET
Investigating
Customers are reporting issues reaching us by phone, we're investigating the issue.
In the meantime, please contact us using support@glesys.se.
This doesn't affect our elevated SLA phone-number, if you have an SLA-pin code you can reach us at 08-525 093 41
Posted Mar 02, 2021 - 10:47 CET
This incident affected: Other.