E-Mail
Incident Report for GleSYS
Resolved
We have identified and corrected the problem. Queued E-mail will shortly arrive to customer’s mailbox.
If you still do not receive any E-mails, please contact our support.
We apologies for any inconvenience caused by this issue.
Posted Feb 17, 2017 - 12:32 CET
Investigating
We experiencing technical difficulties that results in our customer does not receive any e-mail.
We are currently investigating the problem.
Posted Feb 17, 2017 - 11:32 CET