Active phishing attack in GleSYS name.
Incident Report for GleSYS
Resolved
This incident has been resolved.
Posted Feb 26, 2024 - 12:01 CET
Monitoring
Still keeping an eye on the development of the situation.
Posted Feb 19, 2024 - 12:21 CET
Identified
We've gotten reports that right now there is an active phishing attack going on informing about domain renewals. Please be aware, You can always check status of your domains from our control panel.
Posted Feb 12, 2024 - 08:10 CET
This incident affected: Other.