Mail services
Incident Report for GleSYS
Resolved
The problem has been fixed.
We are sorry for any inconvenience this may have caused you.

If you still have problem with our mail services, please contact our support.
Posted Aug 17, 2016 - 14:24 CEST
Investigating
We are currently experiencing a problem with our mail services.
Posted Aug 17, 2016 - 14:12 CEST